首页 / 问答 / JavaScript/js等的前端开发中npm WARN config global `--global`, `--local` are deprecated的问题如何解决呢?

JavaScript/js等的前端开发中npm WARN config global `--global`, `--local` are deprecated的问题如何解决呢?

javascript nodejs npm 211 次浏览
0

在最近安装的nodejs 16.15.1版本中,使用npm命令时多了如下的提示:

npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead

这虽然是一个警告提示(不影响npm的正常使用),但对有强迫症的人来说,对这种警告也是零容忍的,必须想办法把它解决掉。

提示的意思大致是:npm的全局配置--global, --local被弃用了,需使用--location=global替换。

那这个问题怎么解决呢?

回复 [×]
提交评论
请输入评论内容

1 个回答

  • 0

    在Windows操作系统中,可以使用一个npm包来解决此问题,步骤如下:

    1.以管理员身份打开PowerShell命令行工具,执行如下命令:

    2.使用npm命令安装npm-windows-upgrade

    3.使用npm-windows-upgrade命令升级npm版本

    Rector的个人主页

    Rector

    1个月前 回答

    我来回答